博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
poj_1502_MPI Maelstrom_spfa
阅读量:5091 次
发布时间:2019-06-13

本文共 5164 字,大约阅读时间需要 17 分钟。

                       MPI Maelstrom
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 
``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 
``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 
``Is there anything you can do to fix that?'' 
``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 
``Ah, so you can do the broadcast as a binary tree!'' 
``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 
The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 
Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 
The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

55030 5100 20 5010 x x 10

Sample Output

35    这道题就是求节点1到其他节点的最小值,然后去其中的最大值即可。     代码:

#include<cstdio>

#include<queue>
#include<vector>
#include<cstring>
using namespace std;

const int INF=0x3f3f3f;

const int MAXN=103;
struct Edge
{
  int v,w;
};
vector<Edge>edge[MAXN];
int dis[MAXN];
int cnt[MAXN];
bool vis[MAXN];
void addedge(int u,int v,int w)
{
  Edge e;
  e.v=v;

  e.w=w;

  edge[u].push_back(e);
}
bool spfa(int s,int n)
{
  memset(vis,false,sizeof(vis));
  memset(cnt,0,sizeof(cnt));
  for(int i=1;i<=n;i++)
    dis[i]=INF;
  queue<int >que;
  while(!que.empty())
    que.pop();
  que.push(s);
  dis[s]=0;
  cnt[s]=1;
  vis[s]=true;
  while(!que.empty())
  {
    int u=que.front();
    que.pop();
    vis[u]=false;
    for(int i=0;i<edge[u].size();i++)
    {
      int v=edge[u][i].v;  
      int w=edge[u][i].w;
      if(dis[u]+w<dis[v])
      {
        dis[v]=dis[u]+w;
        if(!vis[v])
        {
          vis[v]=true;
          que.push(v);
          cnt[v]++;
          if(cnt[v]>n)      //超过n次即为有负环
            return false;
        }
      }
    }
  }
  return true;
}
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF)     //若一道题没有说明输入test个数,也没有 输入 0 0 结束之类的,则必须判断 !=EOF,不然会 tle 。
  {
    for(int i=1;i<=n;i++)
    edge[i].clear();
    for(int i=1;i<=n;i++)
    addedge(i,i,0);

    for(int i=2;i<=n;i++)

      for(int j=1;j<i;j++)
      {
        char s[100];
        scanf("%s",&s);      //字符串输入用 %s ,字符用 %c  
        if(s[0]=='x')
        {
          addedge(i,j,INF);
          addedge(j,i,INF);
        }
        else
        {
          int w=0,len=strlen(s);
          for(int k=0;k<len;k++)
          {
            w*=10;
            w+=s[k]-'0';    //记住要  -'0'  
          }
          addedge(i,j,w);
          addedge(j,i,w);
        }
      }
    bool ans=spfa(1,n);
    int max=0;
    for(int i=1;i<=n;i++)
    {
      if(dis[i]!=INF&&dis[i]>max)
      max=dis[i];
    }
    printf("%d\n",max);
  }
  return 0;
}

 

转载于:https://www.cnblogs.com/-maybe/p/4248158.html

你可能感兴趣的文章
各种编码转换
查看>>
BroadcastReceiver的使用,动态注册和注销,优先级和中断控制
查看>>
Python能做些什么及我的Python学习疑问
查看>>
sublime text3的使用
查看>>
白帽子-高端信息安全培训视频教程
查看>>
opencv入门笔记之三 简单图像识别,识别线,点,圆,轮廓
查看>>
InstallShield Limited Edition Project 打包windows服务解析
查看>>
openfire安装完毕后无法登录控制台(忘记密码)的解决方法
查看>>
学习cocos-js的准备工作
查看>>
互联网应用和企业级应用的区别
查看>>
Linux yum源更换阿里云的源
查看>>
微信小程序中使用 <web-view> 内嵌 H5 时,登录问题的处理方法
查看>>
Func和Functor的区别
查看>>
[WPF]颜色主题功能
查看>>
java8 通过Lambda表达式对List 简单排序
查看>>
range()函数在python3与python2中的区别
查看>>
Flask--Python中常用的Web框架之一
查看>>
虚拟机评估——如何确定一个CPU核上部署的虚拟机数量?
查看>>
C++ STL中的 iterator 和 const_iterator
查看>>
【学习总结】win7下安装Ubuntu双系统的日常
查看>>